久々にlaraveを触り”php artisan ser”でローカルサーバを立ち上げようとしたら”fail to open autoload”のエラーに見舞われる。調べたら、composer updateが必要ということなので”composer update”のコマンド叩いたらphpのバージョンが違うよエラーに見舞われる。言われた通りのphpのバージョンをインストールして変更したらようやくローカルサーバが立ち上がった。
不具合の原因はおそらくこう。
- 別の人に修正依頼してpushしてもらった->autoload.phpの欠失?
- MacのOSのアップデート->phpのバージョンが8.0になった
しばらく触ってなかったから環境が変わって不測の事態に時間を取られた。